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Forms 

FrontPage Forms could be used for surveys as well as for tests and quizzes. 
You can create forms with either: 

1. Using a form wizard, by selecting from the Menu bar, File-> New and from the 
New task pane, click on More page templates and then select Form Page 
Wizard 
Or 

2. Insert the form manually into an already existing webpage, by selecting from the 
Menu bar, Inser t > Form, and there you find several types of form elements. 
You can insert Option Buttons, Check Boxes, Textbox, Text Area, Drop-Down 
Box, Push Buttons, Pictures, and more. 
 

Overview on Form Elements 

Option Button  

Use Option Button  when you want your students to choose one option from a list of 
several options, as in Multiple-Choice tests.  Ex.:  

Which city is the capital of Peru? 

Bogotá 

Lima 

La Paz 

Santiago 

  

Checkbox 

Use Checkbox  when you want your students to choose more than one answers.  Ex.: 
Which countries are in South America?  Select all that apply. 

Colombia 

Mexico 

Canada 

Cuba 

USA 

Brazil 
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Textbox 

Use Textbox  when you want your students to enter one line of 
text only.  For example, for Name, E-mail, and short answers.  One-line text boxes can 
also be used for exercises where students fill in the blanks. In this case, one-line text 
boxes would be spread within a text and each box would correspond to a specific word 
the students were expected to type in. 

Example: Name:  

Text Area 

Use Text Area box  when you want your students to enter 
multiple lines of text. For example, answers to open-ended questions, discussions, and 
comments. However, for essays and other longer texts it is better to use regular e-mail 
messages or word files as e-mail attachments. 

Example 

Comments:  

Drop-Down Box  

Use the Drop-Down Box  when you want your students to select 
one option from a list of options.  For instance, if a professor teaches several courses, s/he 
can have all courses in a drop-down menu.  Students would select the course they are 
taking, and from there they would start accessing the material of that specific course. 
 Drop-Down Boxes are also indicated for very long lists, which would take too much 
space in the radio button or the check box format. 

Example: 
English 101

 

Push Buttons  

Push Buttons are mainly used to submit/reset data of the form.  By pressing Submit, 
you send the answers of your form or quiz; by pressing Reset, you clear your answers 
from the form fields. 
 

Example:  
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 Pictures  

You can insert pictures in a Form the same way you 
insert pictures in any FrontPage document. From the 
Menu bar, select Inser t >Picture, and then selecting 
Clip Ar t or From File. You can also insert pictures 
within form fields, when you select from the Menu bar 
click Inser t > Form > Picture. 

 

Creating Forms 

1. Click the mouse on the area of the page where you want the form to appear. 
2. From the Inser t menu, select Form and then select the form element you want to 

insert. This automatically creates the basic elements of a form, including the text box, 
Submit and Reset buttons.   

3. Right-click inside the form and from the drop-down menu, select Form Proper ties. 
4. The Form Proper ties dialog box appears. Here you can modify several Form 

attributes. When you finish, click Ok.   

 

NOTE: The form is bordered by a dotted line.  Any elements you want to include in your 
form must be inside this boundary. If you try to insert a form element outside the dotted 
line, FrontPage will create an entirely new form. 

Inserting Option Buttons 

1. Type the question or text. Then, press the ENTER key. 
2.  From the Menu bar, select Inser t > Form > Option Button.  An Option button 

appears on your page.  
3. Type your text next to Option Button button. Then, press the ENTER key. 
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Repeat steps 2 and 3 to create each one of the other options. 
Right-click each field and open their Form Field Proper ties dialog box. 

 

 
In Group name type a name that identifies the question. In Value type a name that 
identifies that specific option.  Thus, all the radio buttons will have the same Group 
name, and each one will have a unique Value. When you finish, click OK. 

Insert Checkboxes 

1. Type the question or text. Then, press the ENTER key. 
2. From the Menu bar, select Inser t > Form > Checkbox.  A checkbox appears on 

your page. 
3. Type your text next checkbox. Then, press the ENTER key. 

Repeat steps 2 and 3 to create each one of the other options. 
4. Right-click each field and open their Form Field Proper ties dialog box.  

In Name type a name that identifies the 
question. In Value type a name that 
identifies that specific option.  Thus, all 
the checkboxes will have the same Name, 
and each one will have a unique 
Value. Click Ok. 

 

 

Inser ting Textbox 

1. From the Menu bar, select Inser t > Form > Textbox.  A Textbox appears on your 
page. 

2. Carefully insert the cursor just to the left of the textbox and type your  text or  
question. 

3. Right-click on the field and open the Form Field Proper ties dialog box.   
In Name type a name that identifies the item.  Also, adjust the Width in characters. 
Click OK. 
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Inserting Text Area 

1. Type the question or text. Then, hold down the SHIFT key and press on ENTER.   
2. From the Menu bar, select Inser t > Form > Text Area.  A Text Area appears on 

your page.  
3. Right-click on the field and open the Form Field Proper ties dialog box. 

In Name type a name that identifies the item.  Also select the appropriate numbers for 
the field Width in characters and Number of L ines depending on how much text 
you expect the students to enter.  They should be able to see most of the text they 
write, without too much scrolling. Click Ok.  

 

Inserting Drop-Down Box 

1. From the Menu bar, select Inser t > Drop-Down Box. A Drop-Down Box appears 
on your page. 

2. Right-click on the form field to open Form Field Proper ties.  
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Write down a Name to identify 
the Drop-Down Box. Hit Add 
for every item you want to add 
to the Drop-Down Box. 
Moreover you can set the initial 
state of one option to be 
displayed by default. You can 
also select the Height of the 
menu (how many menu items 
will show in the screen when 
the menu is closed).  
You can disable the first option 
by hitting Validate and 
enabling the “disable first 
choice” . Click Ok.   

Note: 
- Filling the form elements and submitting the form does not work when your Web site is 
on your computer only, but after it is published on the Internet.  
- Make sure you keep the Submit and Reset buttons at the bottom of the page. All 
questions and buttons should come before those buttons.   
- To resize a Text Box Area: 
      1. Click on the box. Resizing dots appear on the sides and corners of the box. 
      2. Position the cursor over one of the resizing dots until it turns into a two-way arrow. 
      3. Then, click and drag your mouse to resize the text. 

Validating Data Fields 

Setting data entry rules for a Textbox or Text Area 

1. Double-click the Textbox for 
which you want to set validation 
rules. Be sure to double-click the 
text box itself, not the Submit or 
Reset button.  

2. In the Form Field Proper ties 
dialog box, click Validate.  

3. Then do one or more of the 
following:  

Selecting the type of data to allow in the 
field 

·  Under Data type list, do one of the following: 
o If you do not want any constraints on the field data select No Constraints 

from the drop-down box. 
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o If you want the field data as text select Text from the drop-down box.  
·  Under Text format select the types of characters to allow in the field — Letters, 

Digits, Whitespace (spaces, tabs, carriage returns, and line feeds), or Other  
(different characters, such as commas and hyphens). If you select Other , type the 
characters in the box. 

·  If you want the field data as integer select Integer  from the Data type drop-down 
box, and then specify the character to allow for grouping.  

·  You can disallow any punctuation, allow periods in groups of numbers as in 
“123.456.789” , or allow commas in groups of numbers as in “123,456,789” .  

·  If you want the field data as number select Number from the drop-down box, and 
then specify the character to allow for Grouping and the character to use for 
Decimal points. You cannot use the same character for both Grouping and 
Decimal.  

Making data entry in certain fields mandatory 

1. Under Data length, select Required.  
2. To specify the minimum number of characters to allow in the text box, type a 

value in the Min length box.  
3. To specify the maximum number of characters to allow in the text box, type a 

value in the Max length box.  

Specifying a value constraint 

To specify a value constraint, such as for example requiring the value in the field to be 
greater than 10, do the following: 

1. Under Data value, select Field must be.  
2. Click the condition from the corresponding list.  
3. In the Value box, type the value for the constraint.  
4. To specify a second constraint, select And must be, then specify a condition and 

value.  

Note: The validation rule will use numerical comparisons if the data type is Number 
or Integer , and alphabetical-order comparisons if the data type is Text or No 
Constraints.  

Collecting Data from Forms 

Form results can be collected in several ways.  They can be: 

·  Sent to you as an e-mail message. 
·  Stored as plain text in a text file or as formatted HTML in your web folder. 
·  Stored in a database in your web folder. 
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Sending Form Results to an E-mail Address 

Each time a person submits a form in your website, a message containing the results of 
the form is sent to the e-mail address you specify.  

1. In Design view, right-click 
anywhere inside the form 
boundary and choose Form 
Proper ties from the pop-up 
menu. 

2. In the Form Proper ties 
dialog box you specify 
where the output of the 
form should be sent.  By 
default, the form text is 
saved to a text file in the 
web.  Delete the text inside 
the File name field. 

3. In the E-mail address field 
type the e-mail address to 
which you want to send the 
form results. 

4. Click the Options button, 
and then click the E-mail Results tab. There you set the properties for the results e-
mail, such as the format of the text (Formatted Text is a good option), and whether or 
not to include Form Field 
names in the results. 

5. In the Subject line box, type 
the text that you want in the 
subject line of the     e-mail.  
If you leave this box blank, 
the subject line will be Form 
Results, by default. 

6. Click OK. 
7. Choose File > Save. 

Note: Make sure your form is 
correct, by selecting from the 
Menu bar, File > Preview in 
Browser, and select the browser 
type. 
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Save Form Results to your web 

Form results can also be sent to a text file or HTML page.  FrontPage adds to this file 
every time a person submits a form.  You can make this file visible in your web by 
linking to it from another page, and you can keep it hidden, and use it for your own 
reference only. 

1. In Design view, right-click anywhere inside the form boundary and choose Form 
Proper ties from the pop-up menu. 

2. In the Form Proper ties dialog box you specify where the output of the form should 
be sent.  By default, the form is saved to a text file in the private folder of your web 
(private/form_results.txt).  However, the default file is not very easy to read.  So, we 
will choose another formatting option.     

3. Click on the Options button in the Saving Results dialog box click the File Results 
tab. From the File format 
drop-down menu select 
HTML, the first option in 
the list. 

4. Click the Saved Fields 
tab.  Under Form fields to 
save you will see a list of 
the fields that FrontPage 
will include in the results 
file. 

5. In the Saved Fields tag 
area, include the date and 
time in the form results: 
Click the Date Format 
drop-down menu and 
select a format that you 
like.  Do the same for the 
Time Format menu. 

6. Click OK to close the 
Options window. 

7. Click Send to and in the 
File name box type the 
file name you want to send 
the results. 

8. Click OK once more to close the Form Proper ties window. 
9. Choose File > Save. 
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Save Results as Text Database using different separators  

Form results can also be sent to a text file, 
FrontPage adds to this file every time a 
record of the new submission. You can 
make this file visible in your web by 
linking to it from another page, or you can 
keep it hidden and use it for your own 
reference only. You can import this text 
file to a database like Microsoft Access. 

1) In Page view, right-click anywhere 
inside the form boundary and choose 
Form Proper ties from the pop-up 
menu. 

2) In the Form Properties dialog box you specify where the output of the form should be 
sent. By default, the form is saved to a text file in the private folder of your web 
private/form_results.txt. 

3) Click on the Options button and from the Saving Results dialog box click on the File 
Results tab. From the File format drop-down menu select Text database using 
comma as separator . This will create a text file that is readable by Microsoft Excel. 
However it is always a good practice to use a different type of separator. Under 
Optional second file, type the file name “backup_results.csv”  and change the file 
format to Text Database using tab as separator . This will ensure that if something 
wrong happens to the first database file, we will have a backup copy. 

Creating a Web folder and retrieving the form file result: 
 

In order to retrieve the file result of the form, you should access the web server via a 
different protocol than HTTP. 
This process involves the creation of a shortcut to your account on the staff server called 
web folder. Once created, you will be able to access your website files as if they were 
stored on your local computer. 
 

1. Assuming you are using 
Windows XP, from your 
local desktop double click 
My Network Places. A 
new window will open 

2. Click on Add a network 
place. 

3. Click on Next, this is just 
a wizard helping you to 
create a new Web Folder.  

4. Click on Next 
5. Type the address (URL) 
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of your website and Click on Next. For example: 
“http://staff.aub.edu.lb/~username” 

6. You are asked for a User name and password. Fill in your AUBnet ID and 
password in the required fields.  

7. You are asked to give a name for the new network connection that you have 
created. Type account on staff, and click on Next.  

8. Click on Finish. 
9. A new window will open containing all your website files and folders. 

Note: Although it looks like these files are available on your local computer, they 
are not. This Web folder allows you to see the content available on your website. 

10. Since we have saved the file result inside the _pr ivate directory, double click on 
_pr ivate 

11. Copy the text file saving the form submissions and paste it on the desktop of your 
local computer. Now the file result is saved on your local computer and you can 
analyze it in any application of your choice. 

 
Note: You can use this web folder to perform monthly backup for your website. 
1. Double click on the Web Folder you created. 
2. From the file menu select Edit > Select All. This will highlight the files available 

in the Web Folder. 
3. From the file menu select Edit > Copy 
4. On your local computer create a new folder and double click on it to open. From 

the menu bar, select Edit > Paste. 
Now you have a local copy of all the files available in your Web Folder on the staff 
server and your backup is complete. 

Confirmation Page: 

You can create a confirmation page that will appear after the users submit a form. 
A confirmation page allow users to review the information they entered in a form 
There are three steps to create a Confirmation Page: 

1. Determine Names of items on a form 
2. Create a Confirmation Page 
3. Assign a Confirmation to a form 
 

Determine Names of fields on a form 
 

Before you can create a confirmation page for a form, you need to write down the name 
you assigned to each item on the form. For example: If you used in the form a Textbox 
field to retrieve the name of the person submitting the form, and you assigned “ fullname” 
as the field name. Then, you should write down “ fullname” on a piece of paper. 
 
To know the assigned name for each field do the following: 

1. Double-click the Web page that contains the form you want to use for the 
confirmation page. 

2. Double-click a field on the form. 
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3. A Proper ties dialog box for this specific field will appear. 
4. Write the word that displays the name you assigned to the item. 
5. Click Cancel to close the dialog box. 
 

Repeat the same thing for all the items in the form to write down on a piece of paper 
exactly the same words written in the dialog box. 
 
Creating a Confirmation Page 

 
A confirmation page is a regular web page which will contain static text and dynamic 
text. The static text you type in the confirmation page should be general to serve all the 
readers who submit the form. The dynamic text is based on Confirmation Fields 
identified by the name you assigned to each field on the form. FrontPage will replace the 
name with the information readers enter in the form. 
 

 
 

1. Create a new Web page, inside your website. 
2. Type the text you want to appear on the confirmation page. 
3. Click beside an area of text that describes an item. 
4. From the Menu bar, select Inser t > Web component > Advanced Controls > 

Confirmation Field. The Confirmation Field Proper ties dialog box appears. Type 
the name you assigned to the item on the form. Make sure you enter the name exactly. 

5. Click OK to confirm the information you entered. The name of the item appears in 
brackets on your Web page. Repeat the same thing to all items in the form. Make sure 
you save the Web page. 
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Assigning a Confirmation to a form 
            
Open the Web page that contains the form you want to use the confirmation page.  
Click inside the form then from the Menu bar->Inser t->Form->Form 
Proper ties. The Form Proper ties dialog box appears, click Options to specify 
the confirmation page you want to assign to the form. Another dialog box appears 
called Saving Results, Click the confirmation page tab and click Browse to 
locate the confirmation page that you want to use. 
 

 
Note: to test the confirmation page, you must publish your Web pages and now 
when readers submit the form, the confirmation page you specified will appear. 


